Slow download speed Southeast Asia
Incident Report for Solidfiles
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 04, 2016 - 11:48 CEST
Identified
We're still working to improve download speed for users in Southeast Asia. The root cause is that our main provider to reach this area is having trouble. Traffic is now going via USA instead of directly from Europe to Southeast Asia, causing slow speed and traffic congestion.

We're doing our best to solve this as soon as possible, but sadly there is little we can do since the problem is outside our network.
Posted over 1 year ago. May 24, 2016 - 14:26 CEST