Download speed issues affecting users in Southeast Asia
Incident Report for Solidfiles
Resolved
Reports are saying that the cable is repaired and traffic should be back to normal. If you're still experiencing slow downloads, please send am email to support@solidfiles.com
Posted over 1 year ago. Mar 17, 2016 - 16:44 CET
Update
Unfortunately this looks like a major problem with a submarine cable, resulting in traffic congestion for traffic from Europe to Southeast Asia. Sadly, there is little we can do until the repair work is done. This is not only affecting us, but most of the internet traffic between Europe and Southeast Asia. We are awaiting updates and will keep you updated once we have more information.
Posted almost 2 years ago. Mar 14, 2016 - 03:13 CET
Identified
We are currently working to resolve download speed issues affecting users in Southeast Asia. This is NOT related to the site upgrade.
Posted almost 2 years ago. Mar 14, 2016 - 03:07 CET