Possible Site Errors
Incident Report for Solidfiles
Resolved
This incident has been resolved.
Posted almost 2 years ago. Mar 02, 2016 - 17:48 CET
Investigating
Our monitoring systems have detected possible site errors. This may affect the availability of some or all our services.

Our engineers are investigating and will update with more information as soon as possible.
Posted almost 2 years ago. Mar 02, 2016 - 16:50 CET
This incident affected: Site, Download, and Upload.