Download speed issues affecting some users
Incident Report for Solidfiles
Resolved
Download speeds should now be back to normal.
Posted almost 2 years ago. Mar 12, 2016 - 15:41 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted almost 2 years ago. Mar 12, 2016 - 14:54 CET
Identified
Download speed may currently be slower than usual for users with PT Telekomunikasi Indonesia. Our network engineers are currently working to fix this as soon as possible. Thank you for your patience.

Please note that this is NOT related to the site upgrade we did earlier this week, it is entirely a traffic congestion issue outsite our network.
Posted almost 2 years ago. Mar 12, 2016 - 14:44 CET