Download speed issues affecting users in Southeast Asia
Incident Report for Solidfiles
Resolved
Download speed now looks stable
Posted 9 months ago. Nov 14, 2016 - 16:43 CET
Investigating
We're investigating slow download speeds that affects users in Southeast Asia
Posted 9 months ago. Nov 11, 2016 - 16:03 CET