Possible Connectivity Issues
Incident Report for Solidfiles
Resolved
This incident has been resolved.
Posted over 1 year ago. May 18, 2016 - 07:57 CEST
Update
It looks like this issue is more widespread than we initially thought, and more users may be affected. We've also gotten reports from users who have trouble reaching Solidfiles at all. We're investigating.

If you're affected, please contact us at support@solidfiles.com. Please mention which internet provider you're using.
Posted over 1 year ago. May 18, 2016 - 00:13 CEST
Identified
Download speed from Southeast Asia may be slower than usual due to a major problem with one of our network providers. We've re-routed the traffic through another provider but unfortunately this link is slower than the primary one. Sadly, there is little we can do until they have fixed the problem in their network.
Posted over 1 year ago. May 17, 2016 - 20:58 CEST
Investigating
Our monitoring systems have detected possible connectivity issues. This may affect the availability of some or all our services.

Our engineers are investigating and will update with more information as soon as possible.
Posted over 1 year ago. May 17, 2016 - 15:48 CEST